Case sensitivity issue with AppServer/Webspeed brokers.



  • I know it's bad design, but... ๐Ÿ™‚

    We have an AppServer called esd_test and a Webspeed broker called ESD_Test. This works great, despite being a terrible idea. But, ProTop has a bit of a problem with it. See below from pt3agent.appsrv.debug. asbman and wtbman are able to differentiate these on case.

    [18/10/22@23:24:40.061+0200] P-002656 T-006120 1 4GL -- Logging level set to = 1
    [18/10/22@23:24:40.197+0200] P-002656 T-006120 1 4GL -- ** tt_apsvList gibt es schon mit "ESD_Test". (132)
    [18/10/22@23:24:40.197+0200] P-002656 T-006120 1 4GL -- ** ABL Debug-Alert Stack Trace **
    [18/10/22@23:24:40.197+0200] P-002656 T-006120 1 4GL -- --> chkConfig dc\apsv.p at line 800 (.\dc\apsv.r)
    [18/10/22@23:24:40.197+0200] P-002656 T-006120 1 4GL -- mon-init dc\apsv.p at line 899 (.\dc\apsv.r)
    [18/10/22@23:24:40.197+0200] P-002656 T-006120 1 4GL -- dcLaunch lib/ptsrv.p at line 198 (.\lib\ptsrv.r)
    [18/10/22@23:24:40.197+0200] P-002656 T-006120 1 4GL -- clientLaunch lib/ptsrv.p at line 241 (.\lib\ptsrv.r)
    [18/10/22@23:24:40.197+0200] P-002656 T-006120 1 4GL -- doRequest lib/ptsrv.p at line 481 (.\lib\ptsrv.r)
    [18/10/22@23:24:40.197+0200] P-002656 T-006120 1 4GL -- makeRequest util\pt3agent.p at line 387 (.\util\pt3agent.r)
    [18/10/22@23:24:40.197+0200] P-002656 T-006120 1 4GL -- util\pt3agent.p at line 1640 (.\util\pt3agent.r)


  • administrators

    @jdpjamesp you are right, thatโ€™s bad design.



  • But bad error handling probably doesn't help... ๐Ÿ˜‰


  • administrators

    Zing!


 

Looks like your connection to ProTop Community was lost, please wait while we try to reconnect.