Unable to monitor database



  • I have 5 databases that I would like to monitor (v10.2B on windows 2012 server) and 4 of them work perfectly. The 5th one gives the error: Unable to attach shared memory Global\sharemem.c.spserver.data.ams.amsdata.0, error 0. (1720)

    Has anyone any suggestions please?



  • I asked Kynan to post here to hopefully pool knowledge.

    So far we have tried reducing the -B on the database. This is 32bit Progress executables.
    We have also tried running the dbmonitor manually from an elevated proenv session.

    Neither of these have worked.


  • administrators

    Older 32 bit releases sometimes have attitude problems about allocating shared memory that don't become apparent until a batch client or character client attaches to them. Try starting your databases with -shmsegsize 128.

    (Ok, actually the problem is probably that the old oe10 _progres.exe was not improved to handle larger segments at the same time that the db server executables were.)



  • That has worked. Thank you


  • administrators

    @kynan great!


 

Looks like your connection to ProTop Community was lost, please wait while we try to reconnect.